API - Cannot export page. Code "NoSuchKey"


For my needs, I created a script using the API that allows me to list all available CODA pages, and export them in markdown format. Until November 27, the script worked very well. Since yesterday, I can no longer download the export pages. Rather than receiving the content of my page, I receive this response:

  <Message>The specified key does not exist.</Message>

I couldn’t find any information on this subject there. Would you know where the problem comes from? Knowing that I haven’t touched my script since last time.

Hi @Valentin_ANNEZO - Welcome to the Coda community, and thanks for raising this to our attention. I just tried it myself and I’m seeing the same error. Let me raise this with the engineering team and see if we can get a fix in place.

Hi @Eric_Koleda - Thank you very much for your reply. I’m waiting for feedback from the team.

+1 - I am having the same problem.

Hi @Valentin_ANNEZO & @Joe_Mocker - One of our API engineers has found the problem and submitted a fix. We expect the fix to go live tomorrow. I apologize for the inconvenience and I want to thank you again for brining this to our attention and your patience as we work to solve it.

I tested the export process this morning and it appears to be working again. If you continue to see errors let us know.