Automated datetime type - a bug? How to solve this?

I have text(!) field with values such as “Apr 2018”, “2019”, and so on. I want to use it everywhere as text.
However when I create new calculated field and refer to this field I see that it’s type is DateTime and for “Apr 2018” it is converted to “43191”, however for “2019” it remains “2019”.
How to FORCE coda to use this field as a text field?

Dear @Konstantin_Trunin

With the ToText() formula you can convert " to text", important to consider the column property!
As you can see below, the looked up tasks are displayed at text.


It’s preferable to share a dummy doc, just to make more clear your specific case (settings) and for the community member to be able to find the best possible solution.


Thank you. This works!

1 Like