All Docs suddenly inaccessible

All of my docs are currently inaccessible. As if they’re crashing.
Is anyone ever experience this?

Edit:
Apparently this is only happening to my Edge browser. Not sure what happened. Everything just fine until yesterday.
The docs can still be accessed through Chrome, and smartphone.

We found a problem.

There was an error retrieving files from our servers. Please check if you have a firewall preventing access to the following host: codacontent.io

I’ve tried:

  • Firewall on/off
  • flushdns
  • VPN on/off
  • Clear all cookies and browsing data for ‘All time’.
  • restart PC
  • Attempted to recover version (but nothing can be loaded)
  • Attempted to report via chatbox (but the form can’t be loaded)

Nothing worked…

Getting even weirder:
I just tried installing Firefox and open my Docs with it. I can open them (not crashing), but there’s a notification that I can’t edit them. I’ve tried reopen outside private window, but still not successful. Everything is in ‘View only’ mode. As if I’m a doc viewer, while I’m the Docs’ admin and owner.
Furthermore, I can’t logged out! Not sure WTF is going on…

Unable to edit this doc
Try restarting your browser, or reopening this doc outside of private window, or contact us for help.

Everything works just fine with Chrome. Both in regular and Incognito mode.


So in short, at current stage:

  • Edge: All Docs are crashing upon loading for no apparent reason.
  • Firefox: All Docs can be opened (although taking longer time to load) but are in ‘View only’ mode (while I’m the owner and Doc admin of them), and I can’t logged out.
  • Chrome: Everything works just fine (even in incognito).