API ListRows with Query and ValueFormat:"rich"

I am a little confused as to how the API is using the “query” to check against Lookups with “valueFormat” set to “rich”.


I have a table with items that are sorted by project (these are a lookup of table Projects)
I am trying to query the items to select only by project title.

This has worked in the past (this is an old CLI tool I wrote almost 2 years ago, but have not used recently)
However now I cannot get a query to work.
These are the pseudo queries I have tried: "Project":"{project_title}" or "Project":"{project_rowId}" or as {project_column_id}:{project_table_row_id}

I can of course set the valueFormat to simple or just not set a valueFormat however I have a return object that I am mapping this to, and I would rather not rewrite a “simple” object just for this kind of use case.

Is there a different query format <column_name_or_id>:<value> that I should be using for a lookup name?

Hi @Joshua_Upton - Thanks for bringing this to our attention. I’ve raised this issue with the engineering team and they are taking a look to see if anything has changed recently.

1 Like

Thanks for flagging! This was indeed a bug, where when using valueFormat=rich the query was being compared against the returned value, which has the gnarly triple-backtick escaping when value is plain text. This is now fixed, it will compare queries against the actual plaintext value of the cell now in the same way it does when you’re not using valueFormat=rich. The fix should go live on Tuesday afternoon.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.