Embed with editing permissions would allow for a great integration with Gather "metaverse"

We have a virtual office in gather.town and all our documentation in coda. Since gather allows embeds, I wanted our team to interact with coda docs directly from the map like in this gif:

coda in gather

For example, we have this knowledge base as a nice coda doc where people can just dump some useful links or info. I wanted people to walk up to this giant tree, interact with it to open the doc then edit it.

But AFAIK, embeds are view only (or play mode), so for now we need to open coda in another tab to insert links. And that kinda defeats the purpose of having coda embedded in this metaverse.

In this case, I want only our team to be able to view and edit those docs if possible. But I can assume users will be logged in coda in the browser they use to access Gather.

Is it possible?

Good question! Can you edit this?

Ok awesome that works! So the trick is to make anyone with the link being able to edit and then writing ?viewMode=edit to the end of the url.

If in play mode it says ?viewMode=embedplay, so just replace embedplay with edit

Hey @Rickard_Abraham , is this a published doc?

Just set it to that anyone can edit like this

Then copy embed

Then just replace embedplay with edit :clap:

Although it might still not work inside gather.town because you have to sign in to edit still :confused:

gather.town seems awesome though, I’ve never heard of it!

hmm, things changed a bit but it didn’t work. :pensive:

coda in gather with mode edit

I suspect coda won’t allow this kind of embedding outside of a coda page. I mean, I think your example would run as well on gather or any other website.
I’ll try with a published doc (although I don’t want people from outside the org to be able to open this doc)

1 Like

Yes, Gather is awesome as well!

I think they’re the only ones that got metaverse “right”: It’s inexpensive (you don’t need thousand dollars glasses), easy to learn, fun, and has as much interactivity as one may need for education, remote work, gathering with friends…

And it keeps improving at a fast pace.

1 Like

Doesn’t work with a published doc as well. Says connection was refused right away. The same occurs if I try to embed a doc using the “regular” URL of the doc

1 Like