Error message when running a pack from Samples

I copied and pasted the sample “Upload Images” from

I just keep getting the error message bellow when running the action.
error message

I just can’t figure out why. Is there something wrong with the sample?

edit:

Breno

Hi @Breno_Nunes - I think the “Connection or proxy not found” error is expected, if you try to use a formula requiring an account and haven’t set one up yet. The real failure seems to be happening in the Authorization initiated log entry. Can you expand that and show me what it says?

EDIT: I found what I needed to do here.
I’m going to try it now. Let’s see if it works.
Thank you, @Eric_Koleda

That error indicates that perhaps you haven’t entered your Google client ID and secret into the settings screen of the Pack. That’s required before you can sign in.

H, @Eric_Koleda
Sorry to bother you again, but this oauth is kind of tricky.
I got another error message.
Could you please, take a look?

You never need to apologize @Breno_Nunes, this is what I’m here for :slight_smile:

So that error is due to a change in the platform that I haven’t fixed in this sample code yet. You can get rid of it by added disableAuthentication: true to the request that downloads the images. Even after you fix that it will still fail, I found out today, due to a new bug with file uploads. I’ve reported it to the engineering team and I hope they will fix it soon. For the time being you might want push pause on this particular samples.

1 Like

Thank you @Eric_Koleda.
Could you please, update here when the bug is fixed.
My idea is to adapt this code to upload and, at the same time, rename pictures to Google Drive.
It’s feasible, isn’t it?
I’m trying to understand the code first. It’s not an easy one.

Sure, I’ll let you know when the bug is fixed. It should be fairly straightforward to adapt this code to work with Google Drive uploads.

1 Like