Seg Fault running Hello World in codespace

Hello,

Executing the hello world example from the packs-starter repository in the codespace it sets up results in a segmentation fault.

Steps:

  1. Go to GitHub - coda/packs-starter: A starter project template for creating a Coda Pack.
  2. “Open in codespaces”
  3. Run npx coda execute pack.ts Hello "World" (as instructed in the template)

Terminal output:

👋 Welcome to Codespaces! You are on our default image. 
   - It includes runtimes and tools for Python, Node.js, Docker, and more. See the full list here: https://aka.ms/ghcs-default-image
   - Want to use a custom image instead? Learn more here: https://aka.ms/configure-codespace

🔍 To explore VS Code to its fullest, search using the Command Palette (Cmd/Ctrl + Shift + P or F1).

📝 Edit away, run your app as usual, and we'll automatically make it available for you to access.

@jfeldstein ➜ /workspaces/packs-starter (main) $ npx coda execute pack.ts Hello "World"
Segmentation fault (core dumped)

I get the same result running it locally, but thought the codespaces example was more reproducible.

Hi @Jordan_Warbelow-Feldstein - Welcome to the Coda Community! I’ve run into this myself a few times lately, but I’ve had a hard time tracking it down. Sometimes when I create a new codespace it doesn’t segfault anymore. It segfaults on my laptop but not my desktop. It’s tricky.

What I do know is that it’s only an issue on Node 19. So if you downgrade to Node 18 (nvm use 18) it should be solved. I’ll raise this with our engineers though and see if they can locate the root cause.