Trouble with Cross-Doc Actions

Looking for anyone who’s been able to implement Cross Doc Actions - hoping to re-build a few of our docs employing them but we’ve not been able to get the Cross Doc Action “push button” to work properly. When you go to connect the action to a column, it doesn’t find anything. Any one using Cross Doc Actions that have had any issue like this? we’ve been talking to support this last week and they confirm we are implementing it correctly but it’s not working - they even got back to us to have us try using them only on the main table rather than a view (super odd, since one of the whole points of cross docs is to be able to only bring a subset of a table to another view) but that hasn’t worked either. I’m guessing we are missing something. Any ideas?

Looks like it might have a been a bug - since suddenly all our implementations are working!

Thank you for posting back that it’s working!

Sorry it was a little bit of a headache to get going, but glad it’s up and running now!


Looks like this hiccup could mean something’s cooking for the Xmas :slight_smile:


I can see this already. There’s a list of choices now to push a button or add/modify/delete a row. Although the UI to set up add/modify seems incomplete (there’s no UI to choose columns and enter values), it can already be used in formula mode. But I guess there are still going to be changes, since referencing a remote column by column name and not some stable identifier seems too error prone.


Back to not working. We’ve switched to hand writing formulas for now.

I’m getting the same result as that screenshot in the original post.

There are a few tricky, but necessary, things to get Cross-doc Actions working properly. One of the more hidden things is the API connection that created for Cross-doc to allow one doc to act on another. This is usually what needs to be solved when you’re not seeing pre-loaded items.

The other issue that was popping up was Cross-doc Actions was intended to work on the main table and not on views. Essentially, a view is the data of the main table, but this sort of “chaining” of references wasn’t something we had included in the very first version. This has since been fixed to work with views for all options except “Add Row”.

To add an API connection, you can follow these steps in the secondary doc where you’re setting up the Cross-doc Actions button.

Open your button settings and under “Choose Account”, click on “+ Set up another account”.

You may see connections listed here already and there may be one that works. It needs to connect to the correct doc and it needs to have “Read and Write” permissions. It’s okay to setup an additional connection individual buttons though too. To setup a new connection, just click “Add new account”.

Choose a name that’s descriptive enough for you to know what it is if you need to choose it from the list again. And it must have “Read and Write” access. Then click “Continue”.

And click “Complete setup”.

You should now see your button options listed.

One last thing to mention is to make sure you’ve synced your table recently so all information is brought in. If it’s a sync from before you added a button column, it may not come through.

Also, see our Help Article here:

Well, I upgraded to the Teams version just to implement cross doc actions and I can’t get them to work. I have read/write access to the table. The button says it completed 1 external action, but there is no evidence in the original doc that the action occurred. Anyone know what else I should check?

Hey @Susan_M_Davis! I recommend reaching out to support directly so we can take a closer look at your doc and your setup to help troubleshoot. You can reach support using either the question mark icon at the bottom of the screen when logged into Coda, or emailing!

I did and we figured out that there is a problem when pushing a button that calls another pack. Not sure if it happens with other packs but if the button uses the gmail pack it seems to not work. Support is looking into the why and in the mean time, I didn’t need the gmail action (it was leftover from a prior workflow I was using) so I removed it and BOOM, cross doc actions work!

Woohoo! So glad to hear that our team was able to get that solved for you @Susan_M_Davis

Coda Support is fantastic! Thankful for the dedicated team.