Cross Doc Not Pulling in Table Data

I have a table with a number of columns in one doc (“Table 1”), and need to provide read access + the ability to update one field to a doc for another department (“Production”) in our company.

When I first set up the Cross-Doc in Production’s doc, the Cross-Doc action was working, pulling in everything from Table 1. I then created a button in Production’s Cross-Doc table (“Table 2”) to update one field in Table 1. The button was working to modify Table 1 with the Production team’s field update in Table 2 + button-click.

Now, Table 2 is no longer populating with Table 1’s data. I have removed the Cross-Doc from Production’s Doc and tried to reinitiate it a few times, but still, the Cross-Doc action isn’t working to pull any of Table 1’s data into Production’s doc.

I have experimented pulling in other tables (other than Table 1) into Production’s doc using Cross-Doc, and find that it works. But for some reason, Cross-Doc will not pull in any data from Table 1.

Table 1 is extensive and would require a lot of work to delete it and rebuild the table with its various Views and workflows triggering off of it, so I am hoping someone might have ideas about why Cross-Doc is failing to pull in Table 1’s data into Table 2?

Attached is a screen capture. Thanks for any guidance.

I’m having problems with Cross Doc today as well. I cross doc’d two tables over the weekend. Both worked fine. This morning, one of them refuses to sync. Even deleting it and re-adding it doesn’t correct the problem.

Hey @Chad_Ralston and @Susan_M_Davis ! So sorry to hear you’re running into these issues. Our team is currently investigating a few issues related to Cross-doc and we’d love to look into this for you as well. Can you please email support@coda.io with links to both your source doc and cross-doc’d doc so we can see if the issues you’re encountering are related?

Please be sure to share these with Support as well. You can do that by going to the Share in the top right-hand corner, clicking the button in the top right (to the left of the “X”), and toggling on Share with Coda Support.

1 Like