API is not working to update user permission in a doc

I am trying to integrate coda, make.com and member stack.

Step1: trigger when new member added in member stack

Step2: duplicate a doc in coda

Step3: add new member into newly created doc

I am having problem with step3, can you pls clarify that coda actually allows to add new users etc via api & if yes then what’s wrong with my approach.

It constantly shows me 401 and 404 error despite checking 100 of time all info is correct cant understand why its happening, 404 mean doc not found and 401 mean API unauthorized.

Both doc and api token is correct and have all permissions, dont know why its not working

Or is any other way to achieve these results would love to know that.


Hi I have this setup on my website at the moment https://imaginaryspace.co.uk/

Its still working so yes the API is still alive!

Can you please share your source via DM or here with the api key removed and I can help you out?

1 Like

I think the API doesn’t allow you to modify new/copied docs right away, and you may need to wait a minute after the copy before you start modifying the sharing settings.

1 Like

Thanks Eric, I also tried after a day it didn’t worked out.

Harry, appreciate that where can I DM?

You can also open an issue with Coda support, and they can help you troubleshoot the API calls.