Can't type in '3 marketing' as String in any table

Hi, it seems like for some unknown reason, I can’t type in “3 marketing” into any table as a String. And therefore, cannot be formatted.
If the value typed in, it will be read as integer of “36953” when the column type changed to number.

Does anyone experience the same weird phenomenon as me?

Hi @Sathya_Thunger :blush: !

I can reproduce on Mac and Chrome :face_with_raised_eyebrow:

The Text field from my side of the screen after copying/pasting “3 marketing” gets converted into a date field :face_with_raised_eyebrow:

I was able to get the Text field back (and “3 marketing” displayed normally), after copy/pasting by undoing my last action with ⌘ Cmd + z (which is a bit strange… as my last action was not converting a field but copy/paste “3 marketing” somewhere in a text field)

3 marketing

Add-On: Typing “2 marketing” also trigger an auto-conversion to a date :sweat_smile:

3 marketing - Typed

I tried “2 dogs” and “3 fishes” after that thinking the number could trigger this behaviour but that wasn’t the case …

The only work-around I can see would be to simply convert the field into a text field once it happens.
As far as I’ve tested this, once the text field is set as a text field again, it seems stable and the issue doesn’t reappear :woman_shrugging:

this looks like a rerun of an ancient bug in excel, where numbers followed by a three-letter month-name were converted into dates regardless of the rest of the text!

3 marketing and 2 marketing

so 25 decorators should give you a date in december!



Oh my goodness :dart: ! That seem to be exactly it @Xyzor_Max :raised_hands: !!!

Just tested with “24 decorators” and Coda gave me “12/24/2001” while converting my text field into a date field.

I tried to copy the returned date from the table and paste it here but Chrome insisted to paste “24 decorators” instead … So my text “24 decorators” still lives somewhere while being displayed as a date in Coda.

1 Like


I have a doc with a field with RTR-010-010 and … -020. There is another field where I concatenate a description to the back.

The concatenated field then starts with a number, I assume date, but RTR-010-030 remains as is.

Support is digging into that. Sounds like another case of misinterpretation.

Maybe Coda should stick with the data type we have assigned to fields…


Ah, the good old unhelpful Coda data type detection… :slight_smile:

1 Like

Hi thanks for confirming it. Unfortunately, if the field changed to text, it would indeed display the text back. But the value inside somehow still recognized by coda as date. And the text won’t be able to be formatted using colours, etc. And if the cell referenced by another column, it will be rendered as reference instead of plain text.

So apparently somehow Coda recognizes the number followed by three letters as date. Even if the letters are part of completely different words.

Yes, I sadly can confirm that too :pensive:
(The [Column 3] in the screenshots below is my “converted back” text field)

Same goes within canvas formulas …

So what happens within that “24 decorators” row definitively spreads everywhere :pensive:

If you haven’t done so already, I would suggest you to contact the Support with this, through Intercom :pensive:


Oh I’ve contacted support and reported this bug via the chat box a few weeks ago.
I just brought this up here since there still no response about this whatsoever, which makes me think if this somehow only happened to me or this is a general bug. But now I can confirm that this is general Coda bug.
Hopefully someone will fix it soon. :slight_smile:


Thanks for reaching out to let us know about this issue. Our team has identified this as a known bug and we’ve added your report to our team’s bug tracking system.

We will be sure to post updates here as we have them! Apologies for any disruption that this may be causing in the meantime.