Coda Published forms not showing the lookup values from same table

I have created a table “Project”, which has a another column “Parent”. the Parent column is look up column as i wanted any other project can be parent. this works perfectly in a table or detailed layout. but as soon as i create published form, the form doesn’t show values in parent field, any idea what i am missing?

my project

the published form is at Create Project

Appreciate if some help here.

Hello @Manoj_Gupta_Engrg-SW_IN ,

Did you turn on all lookup columns in the privacy settings of your form. Not sure if that’s you problem, because I can’t see your document since it is locked, but I have had forms where this setting had to be turned on.




Hi @joost_mineur
Yes I have enabled this option, see the picture below.

sorry for permissions to the document, I have now opened it.

Document: Sanbox

I think it’s the same topic of this:

Let’s merge into this one

Hello @Manoj_Gupta_Engrg-SW_IN ,

I think the problem is that your lookup column is a column in the same table. Make a small table with the projects and call it ‘parent’ (or any other name), fill the 1 column table with your project names and use that as the lookup column. That works for sure. The way you have set it up is asking for problems, because when you delete rows at some point in the future from your projects table, the lookups will fail.
I am kind of surprised it is working in standard view (and it is), but a form needs to do lookups from a ‘master’ lookup table.


1 Like

i want to create tree structure or projects. one project can block another project lookup has to be from project table only.

Is there a reason Project A has itself as a parent? Seems like something that could cause issues, but maybe not.

Hmm… So i just checked with my Projects table… and in the non-published, still editing the form view in my doc, I saw the following with No Options available. It turns out, I have a filter rule on the Parent Column, that says only give me parents based on my selection above (department, division, project). Since I haven’t selected anything, no parent is available yet to select.

Do you possibly have a filter rule?
Also, is it showing correctly when you are in your Coda page, but not on the published link? Or not working in both places?

Am going to try creating a published link and seeing if it works for me there.

it works on coda page, but doesn’t work on published page.

Do you get an error on the published page? Can we see a picture of the published page? I am getting the following when I hover over the red triangle on the published page. I have enabled the lookup permission as well.

Edit: Never mind, that was probably still without updating the permissions. I no longer see an error.

Maybe we can tag this as Bug… looks like I am having the same issue (see below). Have you tried asking the coda team using the QuestionMark at the bottom right of your screen?

Published Form: (Does not have projects when i select a tree type)

Form in Coda Doc: (Has projects when i select a tree type)

So, I actually worked directly with tech support on this issue, and it turns out this is intentional on Coda’s part. Essentially, it’s a data protection issue, and last I checked they were not interested in changing it.

1 Like

Here’s how I worked around what I think is the same issue.

I had a form where the user is asked to select a Subtype of a Type, but where the Type is predetermined and need not be selected.

In coda, the table and the form view both work by filtering Subtypes where the Subtypes’ Type equals the predetermined Type.

But this filter was not working for the published form; no options appear.

I admit I don’t understand why this would be desired behaviour.

But here’s my solution:

  1. Add a column to the table that looks up the Type, then change the filter on Subtype to filter by the selected Type.
  2. Hide the Type column from the form.
  3. Enable the “Include hidden columns for URL parameters” option.
  4. Include the desired Type to be selected in the form URL by adding ?Type=predeterminedTypeName

Hope that helps someone! :grinning:


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.