Craftmypdf is not return server?

Anybody has been using this Craftmypdf pack recently?

I havenot tried it before. I want to try and so i set it up and test with button. However, the error show that it is not return server.

I would like to know if i did it wrong or craftmypdf pack is not reliable to work with

Hi @Korn_Tris,

I have just set up the pack and created a basic PDF.

I had trouble initially as I made passed an incorrect JSON value however after that it was fine.

You may need to revisit you configuration. Double check the Template ID is correct and check your JSON.

I used just this simple one as a test:

"{\"company_name\": \"LOGO Consulting Pte Ltd\"}"

The template I used was simple invoice. Try adjusting this to a JSON element from your own template if company_name doesn’t already exist to try.

All the best


Hi Dale. Thanks for you advice.

I don’t have any knowledge about JSON. I just use BUILDDATA (Formula) from craftmypdf Pack to push value out.

Can you show me your doc how you put this JSON in?

“{"company_name": "LOGO Consulting Pte Ltd"}”

this one is not working

Hi @Korn_Tris,

It looks like you have misspelled the key company_name.

Please correct and give it another go.

If you get another error please try and get a screenshot of it and post it in a response.



@Dale_Cowling I have edited and tried. Still the same error

Hi @Korn_Tris,

Sent you a DM with a test doc.

Let me know how you get on.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.