Request error status 0 - is online? true

I am working on a pack in the browser, making changes and testing them in a doc.

May 25, 2022 at about 10:40AM Eastern the Buils would work but I started getting the error: * Request error status 0 - is online? true*

I tried a coule of different packs I have and the same result.
I also tried a different browser to no avail.

Everythng was working fine up until then.

I’m also getting the message *
Failed to get marketplace information for Pack.* when I first hit the Edit Pack button.

There is also a message Your code contains private unbuilt changes. at the bottom that I figure is related to the issue above.

Not sure how to proceed…

Hi @Robin_Thompson - Sorry to hear about the trouble there. The “Failed to get marketplace information for Pack.” error is a known one, and I think is fixed now, but didn’t have any impact on the Pack Studio. For the “error status 0” error can you post a screenshot of the logs?

Hi Eric,

I apologize for the delay in getting back to you.

I also really appreciate you reaching out to me directly.

Here is the error that I kept getting. They were all the same.

Overview: Formula ProcessSyncSets failed: Connection or proxy 6fd3616a-3da3-476c-8b3c-c41326b897de not valid for formula type action

User ID
470145

Pack Version
104

Pack ID
10448

Request ID
9dc71908-1ed0-491b-8b69-c974d1843bbe

Created at
May 29, 2022 @ 00:33:20

Request type
invokeFormulaRequest

Duration
237ms

Error
Connection or proxy 6fd3616a-3da3-476c-8b3c-c41326b897de not valid for formula type action

I was dorking around with Authentication stuff. I had started with System Authentication and got that to work. I then changed that to User Authentication to see if I could get that to work. I started experiencing the issue at that point so I thought it was something I had done. The final go at that is V102 attached. I reverted the code to an earlier version that used System Authentication (V104 attached) thinking that would sort it out. Unfortunately it did not.

I tried a different pack that I’ve been using in production and added it to a document. I got the same error.

At this point I assumed something must be up at the server. The Status page showed all green and I decided that this was new and would likely resolve itself eventually.

I don’t think I mentioned in the post that I also couldn’t get access to the pack marketplace either during this. This is what ultimately convinced me it was not just my code. :slight_smile:

I tried again the next day and everything was working as expected. I haven’t gone back to the User Authentication code yet. I haven’t had that issue since.

I hope this helps.

If there’s anything else, please let me know.

Have a terrific day!

Thanks again,
Robin

(Attachment Data Sync - V104.ts is missing)

(Attachment Data Sync - V102.ts is missing)

I see, thanks for the additional details.

Connection or proxy 6fd3616a-3da3-476c-8b3c-c41326b897de not valid for formula type action

This error means that the connected account you are using was setup in such a way that it doesn’t support actions, likely because it was created at an earlier phase of your Pack’s development where there were no actions in your Pack. Deleting the account and creating a new one should work around that.

I’m glad to hear the other errors are resolved now, perhaps it was a temporary outage of some sort.

Thanks.

I was dorking around a lot so it’s highly likely I got ahead of myself… LOL!

Thanks again