Document crash that can't be recovered through version history

I had my productivity document crash on me last night. I’ve reached out to support, but responses are slow. Any idea if this is something I can try to resolve without help from the Coda team?

I had built a button in my task table that copies tasks with status “planned” and date "Today()-1), i.e. tasks that I had planned for yesterday but did not get to. As I was testing the automation rule, my document was slow and coda took a lot of processing power. I reloaded the web browser, but got the error message:

I have tried going into my version history and copy an old version of the doc, but I keep getting the same error. I have not used any hidden formulas other than FormatDuration().

First try adding the ?nocalc=true to your URL.

Second try getting into some other page than the one you last were in. Most often it’s something in the page that you’re looking at that triggers the error — if you manage to somehow get into the doc, you can try deleting that page altogether or otherwise editing the doc so that the piece that triggers the error is removed (e.g. you delete the column with the formula that triggers the error).

1 Like

Thanks @Paul_Danyliuk. I tried both approaches with no success. Considering that reverting to a 30 day-old version does not solve the problem, I guess I’ll just have to wait for help from customer support!

Coda support helped me recover the document. They said the crash was caused by a bug related to me deleting and then restoring a few rows. They also said they are working on fixing the bug.

1 Like