External Zapier Results Imports Everything into One Row

I use a webscraper for one of the projects I have been testing in Coda, and that webscraper has a Zapier integration. I recently tried using Zapier to directly connect the scraper’s results to Coda, and the results are being inserted into one row instead of a separate row for each result. I had previously done a similar Zap with Google Sheets successfully, so my assumption is that this is doable and I am overlooking something.

To be clear, here is an example of what is currently happening:


And this is what I would like to have happen:


For reference, this occurred when testing the Upsert Row action.

When I tried testing the same data with Create Row, it got worse. Only one column carried over (e.g. ProductName, not Price) even though the tests on Zapier showed data for both columns. And, like above, all the results got stuffed into one row. (UPDATE: There appears to be an issue/bug where the data being sent converts the Price column to a number format but does not actually send the data).

I know that in a pinch once the data is imported I could setup a formula to parse it and break it down into separate rows, but that seems like an avoidable step.

Checking-in to see if anyone had insight on how to ensure imported data is spread out into separate rows.

Hi @Joseph_B - What does the sample data when you test the Zap in Zapier show you it will insert?

@mallika It shows all of the data in comma separated format, delineated by category.

For example:

ProductName : Apple,Orange,Peach
Price: 1,7,2