Force a "space" within some text?


I am trying to force a space-symbol " " into a set of formulas that use emojis to represent “done” (:white_check_mark:) and am having trouble where many of them next to each other get “smushed” even though I specifically have them set up to be pulled from a table with symbols in it to designate how many checkmarks to put.

I have the checkmark in a table by itself with two spaces after it in order to use this in repeat() functions to designate how many to use; However when I do that the spaces after the emoji seem to get deleted. I’ve tried using concatenation to define the spacebars (i.e. =concatenate(“:white_check_mark:”,character(32)) but this doesn’t seem to work, even though it should appear like this: :white_check_mark: :white_check_mark: :white_check_mark: it always ends up like this: :white_check_mark::white_check_mark::white_check_mark: which just isn’t the aesthetic I’m going for.

I can work up a quick doc if helpful, but just wondering if anyone has tips on how to preserve the space “symbol” so that this isn’t an issue? I’ve tried the transmuting the trick for carriage returns where you use a table with an inserted space as its own cell as well, to no avail!

Dear @Sean_Meehan,

I made a small test setup and as you can see you will get a space between the symbols

Maybe it’s the best to share your sample :thinking:

Hey @Jean_Pierre_Traets - thanks so much for taking the time to have a look at this!

I’ve discovered something interesting; unfortunately it seems like this problem stems from something outside of Coda but I’ll elaborate all the same in case you have thoughts. It turns out that depending on which monitor I’m looking at the file on, it seems to compress the output of the formulas. I’m normally working on an external monitor but when I opened it on my laptop this morning it all looked right, clear as day. I had put in a " |" (space & pipe) symbol for some separation since the space - character(32) hadn’t seemed to be working on its own. On my external monitor, that looks like this:

image (this is “:green_square: |” or, emoji-space-pipe)

versus on my laptop screen it’s displaying like this:
It’s the same exact box in the table, literally all I did was drag the window between monitors.

So something about graphics resolution or whatnot is messing up the way it displays - can’t imagine there’s anything to do with Coda here, I’ll just have to think about how I might create some separation between symbols that will persist regardless of what it’s viewed on - it might just have to be a compromise that some screens will show it as way more spaced out.

If you have thoughts, let me know!


From what you’re saying, this seems like you may have reduced zoom in the page + a HiDPI / Retina laptop screen that scales it back to normal? What browser are you using?

I don’t have any issues with Windows + the latest Chrome, no matter how I zoom

I’m using chrome on a macbook pro (new-ish, I think they all have retina since a few years ago) with a basic phillips external monitor.

I don’t see any coda settings about zoom level - but chrome is set to normal (100%) zoom level and the monitor is set to standard 1080p aspect ratios.

Hi @Sean_Meehan,

I mentioned this to the team and saw something similar happening in some of my docs. It does appear to be a bug that shows itself on Mac Retina devices. The team is checking it out. Not ETA on a fix, but the team knows.

Sounds good! It isn’t a huge detail - the functionality works as expected, just looks a little wonky sometimes. To be clear - the lower image from my post above is from ON the retina screen, while the upper one (the messed up one) is from the same computer, but NOT on the retina - it’s on the external monitor. In case that matters somehow.

Thanks for the feedback. We’re still not 100% sure what’s involved, but will be checking it out.