How to make the Connect to Salesforce prompt appear?

I have a template which features formulas from the Salesforce pack such as LookupRecords and UpdateRecords. When a user creates a document from the template, they are prompted to connect to Salesforce and if they do, the formulas work as usual


If they skip this step, the prompt will not appear again. I have to talk them through how to unhide pages, enable edit, right click a formula, and add an account to the formula. I really wish my document would work out of the box without these extra steps. is there a way to make the initial prompt appear again?

(the above is just one example of how a formula looks if the initial prompt is discarded)

1 Like

These settings are admittedly hidden - but you can access an installed packs general settings, including connected accounts, via the right hand side bar through settings.

Settings > Packs > Salesforce Pack > settings

Once on the pack itself, there is a smaller “settings” available where you can manage connected accounts.

Hi Scott thanks for your reply

Unfortunately, even going into the packs settings do not work the same as connecting via the initial prompt. Only that initial prompt seems to correctly set the account in all the formulas. If that prompt is skipped, even after going to the settings and setting a shared account it will still be necessary to open the formula and choose the account there.

I should specify that the template itself uses a shared account, but that shared account is no longer available for docs created from the template. instead, as I understand it, when a doc is created the prompt appears and connecting to it will replace the initial shared account. the issue being that if the prompt is skipped, it never appears again and all those other steps are required.

here is an example of the aforementioned behaviour: even after setting a shared account in the packs settings I still have to open the formulas and choose an account. that is the hassle I am trying to avoid for my users.

You are almost there!

Where you have circled in your screenshot, on the right, unroll that.

They should be a small three dot option menu that when clicked give the option to “sign in again”

it still doesn’t work for formulas which use the shared account. Clicking […] → Sign in again takes me to the Salesforce login page, I enter my credentials, it all works but I still have to open the formulas and set the account

I also feel like I am almost there but nothing works juuuuust the same as the initial prompt, which is smart enough to set the chosen account in all the formulas

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.