Is it possible to find all public pages in my org?

Problem
I’ve found some documents in my org that were open to the public. That can be a security concern as it may contain proprietary information.

Goal
Either one works:

  1. Prevent or disable pages from being publicly shared.
  2. Display all pages that are shared publicly.

Workaround
I found a way to do number 2 through the APIs, however, that requires some work. I’d appreciate not using the API, if possible.

@Gabe_Leon You inspired me to create a pack with this post!

This pack brings in all of your workspace docs and shows permissions, public access, etc.

Here is a demo page that shows how it works:

Thanks for the idea and let me know if you have any more questions!

3 Likes

Hi Troy,

Thank you! I’m amazed at what you put together so quick.

I tried to use it and got this error:

Couldn’t get updates from Doc Permissions as of just now. Try again in a few minutes or check your settings.
You don’t have permissions to view this data in Doc Permissions

Should I be an admin to use it?

Can you share a screenshot?

Did you create a new doc and install the pack?

Yeah, I did create a new doc.

Can you try as an admin? Let me also add an option to sync docs you have access to . . .

I tried as docmaker admin, same result. I have access to the workspace.

@Gabe_Leon I had a couple other people test it and it worked fine. Can you try adding a new account and take the default security settings?

I’d really appreciate some help to figure out what might be going wrong.

Steps I’ve taken:

  1. Created a new page.
  2. Inserted the “Doc Permission” Pack and initiated it with /docpermissions.
  3. Provided the correct workspace ID.
  4. Selected “Account” dropdown.
  5. Clicked “Set up Another Account”.
  6. Entered my name, left “Access Restriction” blank, and clicked “Create”.
  7. Attempted to run the tool with the “Sync” button.
  8. Encountering an error message.

Additional Notes:

  • I’ve tried granting express permissions to a test document in step 6, but it didn’t resolve the issue.

Wow, this is baffling . . .

  • I had another user try it – worked fine
  • I used another test account (free tier) and installed it from scratch like you did – worked fine
  • I was able to make the exactly error happen only when I modified the Access Restrictions

Can you try with a completely new doc? Also verify you workspace ID (although, when I put in the wrong ID, it didn’t give me that error).

It doesn’t work for me either. I do not receive and error message but no data is syncing. The URL of the workspace ends with /docs. Also, when I click on the link to your website, I am denied access after signing up.

@Troy_Larson I’ve managed to get past the error. If I try to “setup an account” I get that error.

I’m now facing the same issue as @Lynn_vK . I tried creating a public page and running it, but it doesn’t catch that.