JIRA Pack: cannot write Sprint updates


I modified the Planning Flow with Jira template to support just updating the Sprint (customfield_10007 in our Cloud instance) values of an issue. We would like to plan at that level using Coda - it’s annoying to bulk edit Sprints in JIRA Cloud.

I created a manually populated Sprints table in Coda to line up Sprint Names with their sprintID in JIRA. The sprintID is stored as number column in Coda and JIRA and a number is required via JIRA API to update the Sprint of an issue. However, I continually get the following error when using the UpdateIssue button to push a Sprint value update from my Coda doc:


I tried to use the JavaScript Number() function thinking maybe passing that to Values in UpdateIssue button would address this, but I get the same error (see button formula below). Please also see button formula below with example values substituted from “Value change” columns used in Doc. The JIRA API supports Sprint value updates so I’d expect this to work via the Pack. I couldn’t find/access the Pack source code so need some help to address.

Number() function used in values section of button formula:

Jira::UpdateIssue([Jira], thisRow.Issue.Key, 'customfield_10007', Concatenate("Number('",thisRow.[Sprint ID],"')"))

With raw sprintID value plugged in:

Jira::UpdateIssue([Jira], thisRow.Issue.Key, 'customfield_10007', 446)

Thanks in advance!

Hi @Brenden_Beatty
I found this article that might be helpful :point_right: Create and Update Jira Issues from Coda where you can find the Supported Fields for Edits.
For custom fields, you will need to designate the field in the form customfield_[id] where ID is the ID number for the custom field from Jira. This can be found using the steps in this article.

Hi @Leonardo_Rubalcava, as you can see in the provided formulas, I have the correct customfield called out. This is an issue with the JIRA API not recognizing the Coda number format sent by the Pack for some reason.

Hi, any help on this would be appreciated.

Also interested in figuring this out…we should be able to update JIRA Sprints given they have a number ID to update to, but not working for me either