Orphaned Views in Doc Map

So working on a doc I’m trying to recreate a Quicken type register. It was working. I went to make some changes and nothing would work right. Doc just kept popping up with “Wait” or “Exit” popup.

I started abandoning columns and recreating them from scratch thinking there was some corruption. I deleted rows some contained Canvas columns.

Now I find that there are over 400 Views of one table that are all “abandoned”. The only way I can find to remove these views is clicking each one in the Doc Map and then clicking “delete abandoned view”.

Anyone know what caused this fiasco and how to prevent it in the future?

My table only had like 30 rows. So how it came up with OVER 400 items that are abandoned I have no idea. Many of them are duplicate named like Split 1, Split 1 1.

1 Like

I also have orphaned views and tables. This came because I had a canvas with tables in my row. I deleted the canvases to recreate them with the “value for new row” option for canvases.

These objects are not just vestigial, they are causing performance problems because there were dynamic computations inside.

I’ve contacted Coda support to see if they can help me.

1 Like

Yep. Putting tables in canvas columns seems to have some issues. I had to manually delete all of mine. I haven’t tried to do this again since that first post because it was too problematic. Do post if Coda support gives you some “fix” for this issue. I’m curious to hear.

Coda support was great! Within a day, support escalated to engineering. Two engineers got on the support thread and deleted the orphaned objects for me and now I have a highly performant doc again.

I hope they also recorded the reproduction so that they can have a true fix for the root cause.


That’s great! Yeah Coda support folks are the best! I’ve never had one not do a fantastic job helping me with something even if it’s something stupid I did and not really their problem to solve.


@Ed_Wei @Susan_M_Davis Makers like you are what make our Support team’s day. You’re so awesome! Thanks for these sweet messages :blush:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.