Problems with Multi-Select Options from Button Action

Hi Coda Community,

I’m transferring data from a Source to a Target table using a button. Both tables have identical columns by name and type. This process works well except when transferring multi-select values with more than one selection.

Single selections transfer correctly and are recognized as individual options in the Target’s multi-select column. However, multiple selections (e.g., “Tenant, Agent, Due Diligence”) are treated as a single string rather than separate options.

All involved values (“Tenant”, “Agent”, “Due Diligence”) are valid options in the Target table’s multi-select column.

I want “Tenant, Agent, Due Diligence” to be recognized as separate selections in the Target table after transfer. Any advice on how to ensure multi-select values are correctly parsed into distinct options?

hi @Monroe_Claycomb ,

add ListCombine() to the function, then all items are taken together
cheers, christiaan


Thanks, Christiaan.

Can you clarify where ListCombine() goes? On the Target side column? Or in the Source side button action?

I created a helper/intermediate column in the Source table with your ListCombine() suggestion. I may have overcomplicated it, but currently it is

ListCombine(split(thisRow.Type,", "))

This seems to be splitting the string into multiple parts as desired, but in so doing, I’m unable to have any defined data validation since now the column is a formula. I’m getting this message

(Options automatically calculated)

I feel like the data is now parsed to be interpreted as multiple values as desired, but I can’t match it to any option data validation since it’s now a formula column.

What am I doing wrong or missing?

hi @Monroe_Claycomb ,

I can tell you what I am missing and that is a sample doc that shows the issue.

Without that, I have to guess and would like to suggest:


this suggestion is as you see without the split, the items should be recognized. May that not be the case, please turn the column into a relation. You create a second table with these items in the display column, one per row) and the you can reference them easily.

Cheers, Christiaan

1 Like

This is weird–the multi-select column issue I’ve been having simply resolved itself after I created the below sample document as you requested. TF!

  • I created the separate sample document to share and test out the functionality that was giving me trouble. To my surprise, the sample worked exactly as originally intended.
  • Returning to my original document, which I had simply closed and then reopened with no alterations, I found the multi-select column issue had vanished, and everything functioned perfectly. Prior to this I had spent hours troubleshooting with no resolution (even with occasional browser refreshes).

This spontaneous fix has me puzzled, especially considering the real-time nature of Coda’s processing, which shouldn’t delay formula updates or fixes, particularly in documents without heavy processing.

Has anyone else experienced self-resolving issues in Coda?

You’re welcome to check out the doc, but it’s working fine–both buttons. So my original question somehow resolved itself, but now has me wondering what actually happened.

I don’t know why, but glad it got solved, the sample doc proved to do the trick :wink:
cheers, christiaan


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.