Remove cell/data from related table when picked by "parent" table

Newb here. I tried finding this answer in the forum, and didn’t have any luck…

I would like to remove a cell/data from the related table when a user chooses it from the “parent” table.

I’m using a dropdown list column on the parent table, which references the related or “child” table. When a user picks a selection from the dropdown on the parent table, I would like it removed from the related child table so no other use can pick it again.

For context: we’re using this to create product numbers. One part of our nomenclature is sequence of numbers, and we need to be sure that the sequence is not used more than once. Of course, there is the solution of conditional formatting/highlighting duplicates. But that would rely on users “guessing” which one hasn’t been used, which is not efficient.

Here’s a link to my test (sorry very crude). But the column in question is “Seq Num”: SKU Generator Copy

Hi @Otis_Martin and Welcome to the Community :partying_face: !

I’m not sure if I understood correctly your question here but from this :

I guessed you wanted a “self-pruning” selectable options lookup field [Seq Num] :innocent:
And I modified your doc accordingly to this (Thanks for sharing :raised_hands: ).

So, the first thing I did was to add a the “reference by” part of your [Seq Num] in your table Walls.
In other words, it’s a lookup field from your table Products to your table Walls which retrieves the products for which a wall has been selected in the table Products :blush: .

Then, back in the table Products, in the lookup field [Seq Num], specifically in the menu Lookup optionsOption settingsFilter, I’ve added a Custom filter to have only as selectable options, the rows from your Walls table where the field Products (the brand new lookup field) is Blank.
So, the selectable options available in the [Seq Num] lookup field are the walls not already linked to a product :blush:

Is that what you were trying to do ? :innocent:


This is it! Exactly what I was looking to accomplish. Thank you!

My pleasure @Otis_Martin :grin: !

I’m very glad to know that I didn’t misunderstood your question and that it now works as expected :smiling_face: !

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.