Simple Formula Issue

So I have been trying to figure this out for awhile now:

I have two numbers I am trying to divide to get a decimal i can then turn into a percentage. The numbers are my Total Units and Total Units with CC Defects. For whatever reason these numbers don’t look right. I have maybe 350 units recorded right now.

The daily numbers will come out fine, and I don’t understand that, the percentages look sound. Any ideas here? One persons cell for the FPY comes back as a “infinite” number.

And yes, I’ve reversed the order that they are divided into each other.

EDIT:

Here is what I have come up with, if any can let me know why the percentages are coming out good when I subtract 1 from the entire formula that would be awesome. Right now it looks like I have it figured out but am just confused as to how I really fixed it. Why is it working like that?

Here is two screenshots of the formulas before and after. It looks like I was getting the percentage of the failed units, when I wanted the percentage of all the good units, but why subtracting 1 from that would it correct I don’t know.

Formula 1:

Formula 2: (I subtracted 1 from the entire formula)

EDIT: “JK” and " JVT" Will show a error in the formula because they are not under “CC”, this would be normal.

Could you please share a copy of your doc?

1 Like

Thanks for the fast reply, sorry for the long response. I don’t get into my office until I’m done on the floor. I’ve really been considering just taking the initiative to write my own simple database. I love how Coda can make a lot of thinks easy, but I’m getting stuck on writing what should be a very simple formula and it’s been holding me up now for a little while, longer then it should.

My Doc is used in a live production environment, because of this I really don’t want to post anything publicly, but I would be happy to send it in a PM if that works? I really need some insight into why this isn’t working.

I’m filtering by the unit type AND user being specific, and I get a correct whole number, as soon as I try to filter again, I want to use .contain to check if any of my select columns Defect_XX (Where XX is the location) contain the defects in a list I have on another page. As soon as I do that I either get a 0 result or something that is off. if I switch the way I divide them into each other still no avail.

I’m stumped, but I’ll shoot the URL to my Doc to you, please keep it to yourself :slight_smile: I know I have it set up for Play but I personally don’t want the doc to be known at all. Again, thanks in advanced!