SSL/TLS connection error on API calls

I have been experiencing issues with my coda integration lately. I am using the v1 api to insert rows to a table from my website. Everything was working fine until the 16th of September, when I started to get exceptions. Since then, none of my api calls work. I’m using ASP.NET for my server side solution and the error message I get is the following:

The request was aborted: Could not create SSL/TLS secure channel.

I had the same problem with my Zapier integration two weeks before this and they pointed out that Amazon (AWS) has put in place some security measures recently that removed some security ciphers from the supported cipher suites. And that was the reason the ssl/tls connection was aborting.

The Zapier team solved this somehow, because it started to work after I reported this to them. Two weeks later I have the same issue with Coda, so I started to look into this deeper.

I am running Windows Server 2008 R2, so my supported cipher suites are limited, but as far as I can tell, there is at least one that AWS should support according to this page:

I tried to reach out to the Coda support but it was useless. I created a bug report as well, but they tossed me away to the community. Did anyone faced the same issue? Or anything similar?