Prxy settings : cannot use Coda in my company

I am fan of Coda and I would like to use it in my work.
I tried to open my docs on my computer using the network of my company and it doesn’t work.
I can see my home page but when i click on a doc, I see the loading page then noting more …

Its look like a problem of proxy setting; i asked my IT Team but they not ound yet how to solve it
Anyone had this problems ? any idea to solve it ?

Thanks in advance

Hi Fabien,

We’ve seen one instance of something like this in the past. The corporate firewall was rejecting websocket traffic for some reason. You might check with your IT team to see if that’s the issue. Opening the “Developer Tools” in Chrome may give your IT team some pointers. https://developers.google.com/web/tools/chrome-devtools/

Cheers,
Chris

Thank you for the quick answer.
We checked this and try to change somes but still not work …
They told me that Coda call many many url and its difficult to find the one blocked by the firewall

Any way, il will ask them to check again

regards,
fabien

@Fabian_Calais, does your company’s proxy replace SSL certs with their own internal certs? I unfortunately cannot use sites that utilize websockets at my work, including Coda, because of this. Go to any site that is using ssl (almost all do now). Take a look at the certificate path. In Chrome this can all be done by clicking on the lock icon to the left of the address bar. After clicking on the icon, select “certificate” and go to certificate path tab. If the proxy is replacing a public cert with private ones, than this is why websockets don’t work. Your company may be unwilling to bypass this mechanism as they will no longer be able to snoop in on your network traffic. It also allows the outside to request info from your browser, which could be a no no. Many modern sites use websockets to enable chat features, which would require constant client side refreshes to make sure users are getting notified on time.

1 Like