Typeform attachments (not images) not visible

Hi all,
I’ve connected a typeform with my coda doc and when I connect a question that has attachments that are not images (in this case it is a .7z) I see a “preview unavailable” message.

I’m wondering if it is possible to get the link instead of an image preview like I would get in google sheets.

I’ve already tried changing the column type to link and text but this is the link I get: Coda | Everything evolves, the evolution of documents.
When I click on it, it redirects to the same doc and I get the message: “table was deleted”

Has anyone else faced this problem? and how did you solve it?

Thanks in advance! :slight_smile:

Screenshot 2023-03-07 173708

Hey Camila! Since .7z files are compressed files, we unfortunately don’t support previewing them in Coda, whether that’s part of the Typeform pack, or even just dropping a .7z file into the canvas.

That being said, if the files are successfully being pulled in, even if you can’t preview them, there should be an option to download the file in the top left of the preview when you click on the file:

Is that option available for you, or are you seeing something different on your end?

Additionally, since this is something we currently don’t support, we’ve gone ahead and filed a feature request for you on this topic :slightly_smiling_face:

1 Like

Hi Nicole,
Thank you for your response.
Download is exactly what I needed, my screen is too big and I completely missed the download option.

My only issue is that when I download the file I get a file called:

  • I don’t mind the length of the name but the file doesn’t have a format, I changed it to .7z manually and managed to open it but this might be an issue for the people I’m preparing this doc for. Is there a way to fix this?

  • Also, would it be possible to simply get the download button or a link to the original file instead of having to open the preview and click download?

Thanks again for the support :wink:

Hey @Camila_Mosso unfortunately the answer to both questions is no. That workaround you have for manually changing a file type is the best workaround for that first query. We’ve added this feedback to that feature request vote though! Sorry for the inconvenience.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.