Bug: @references

#1

Since there is no Bug Section in the forum:

@references do not work in docs when using a German :de: keyboard layout. Everything works perfectly when I switch it to a US or UK version.

This is not a big inconvenience, but in case of others having the same problem, I wanted to share my experience.

1 Like
#2

Hm I work with german keyboard layout and it is all fine for me. Which Browser & OS do you use?

#3

weird… so it seems to be a

I am on Windows 10 (Asus Zenbook) and using Chrome.
On my laptop “@” is on crtl + alt + q.

As I said - all I need to do is change to a different keyboard layout, and it works. Will try it on a Mac tonight.

#4

So it is working properly on the Mac I tried it on… @Daniel_Stieber I guess you are using a Mac as well?

#5

Yeah totally. I now tried it on windows and it is not working for me too there. mabye @nathan can help :slight_smile:

1 Like
#6

@Daniel_Stieber @Philipp_Alexander_Asbrand-Eickhoff looking into it!

1 Like
#7

Hey @Philipp_Alexander_Asbrand-Eickhoff @Daniel_Stieber, engineer here that worked on international keyboard support! To clarify:

  1. Where are you typing? E.g. canvas, table cell, etc
  2. What’s happening when you press CTRL+ALT+Q? Is any character being inserted?

Let’s get to the bottom of this!

#8
  1. I was typing on the canvas
  2. the @ appears, but it does not trigger anything else. Just like when I would enter any other character.

When changing the keyboard layout to US, it works normally (SHIFT + 2).

image

#9

Thanks @Philipp_Alexander_Asbrand-Eickhoff – I managed to repro on my end too! The fix will require some work but I’ll update this thread when it’s done.

3 Likes
#10

Great! otherwise I could have given you access via teamviewer.

Since there is this super easy fix to just change the keyboard layout, I would not give this bug the highest priority - but that’s just my opinion :wink:

#11

I also ran into this issue, but I think the regional/localization settings need some polishing in general :wink:

#12

Hi @Philipp_Alexander_Asbrand-Eickhoff, @Daniel_Stieber, @mlenhardt:
@irvinzhan19’s made a change that should address this and allow you to add a reference by entering ‘@’ from any keyboard - let us know if you still see this issue.

Thanks!

1 Like
#13

Thanks a Lot, will let you know if I still find errors :slight_smile:

#14

This works for me now, thanks for fixing it!