Calendar views shouldn't expand hidden columns area when opening a row

Summary of issue

When a row is opened from a calendar view by clicking on it, it opens up the “show hidden columns” area.


  • Calendar views label their events based on the Display Column.
    • Often, you want to generate a Display Column via a formula, in order to combine a couple key data points into a glanceable summary. In our case: the person involved, and the name of the event.
    • This column isn’t editable though, so we want to hide it away when we’re opening up a row to edit its details
  • Let’s open up a row to work on it
    • If we hover on an event and click the maximize button, it opens as a row from our base table (not our calendar).
      • The hidden rows are hidden, and everything is great
      • Our cursor is in the first field in the row layout
    • If we just click on an event, it opens as a row from our calendar view. Unfortunately, the hidden columns area has been expanded and all our hidden columns are displayed.
      • Coda tries to place our cursor in the display column field (but since it’s formula-based, this has no effect except to expand the hidden columns area)


I don’t think it should work like this (and don’t think it used to work like this). It should always respect the row layout settings, and should open with no particular field selected (or the first field in the layout selected, as it does when expanding the row of the base table).

(Separately I am also a big believer in the value of having different display columns in different views, but that’s a proposal for another day)

Full details & demo here:

1 Like

Support believes it to be a bug and are working on it :+1: