Can´t use a control to filter a table

Hi guys
I am struggling to filter a table from a control.

I want the user to be able to select a task from a dropdown.
1- I managed to show only his tasks and those with “doing” status.
2- I applied the filter to the table, selected “Task” and applied the control. The filter resulted in 0 rows.

What did I do wrong? It seemed pretty straightforward.

1 Like

I’m having a similar issue, seems like interactive controls to filter a table behave inconsistently. I have an interactive filter that correctly filters one view of a table, but not a different view of the same table.


There are more ways to do his, but I fixed it so it works the way I think you want it by changing the control and adding a filter with “AND” in the filter option of the table.

Check my view or your table, the new select control and the filter I placed below your original filter.

Hi @joost_mineur

Thanks for your attention.

Your solution is not exactly what I was trying to achieve.
I want to filter by task, so the user can choose a specific task and then visualize it at the table bellow (later I will change it to the details view).

The purpose of this view is to make a work environment for the user. He will choose a task (that have a “doing” or “to do” status) and then the table bellow will open that task in details in order to work on it.

The control that I’ve made was correct. The problem was about how the table used that control to filter the view.

Hope I could make my self clear.

Maybe it is better now? Of course, the filter can be set so nothing shows if the select button is blank - that is a simple change.

It´s working fine! Thanks a lot!