Conditional formatting has wrong priorities

I believe formatting shouldn’t act like this or maybe I’m missing something.

As you can see in the image below, I have two conditional formats. The “Yellow” one is above the “Multicolored” one and should take priority over it. However the program column is not colored yellow in the second row as I would like it to be.

Do color scales always take priority (which I would consider a bug, not a feature :stuck_out_tongue_winking_eye:) or am I missing something? :thinking:

Hey @Fran_Vidicek! Happy to shed some light on what’s going on here. The first rule overwrites what isn’t stated in further rules. The first rule does apply to the color scale formatted column. Here is an example. In the example, the font color is changed from one color to another (according to the first rule) but the background is not changed because it is also fulfilling the 2nd rule.
Hope that helps!

1 Like

So how would I make the Yellow take precedent over the color scale in the background as well?
No matter what order I put them in, the background is always from the scale colors.

Gotcha. This isn’t currently possible, unless color scale is removed, since conditional formatting respects all the rules. I will add this as a feature request for you though, so you’ll be notified if this gets built out :slight_smile:

1 Like

I think the reason here is different. It’s not about color scale — it’s the fact that rules for individual columns (i.e. that affect the format of some columns) override rules for the whole row.

The workaround is to:

  1. unhide (or make) another column that’s not in this view

  2. set your yellow rule to affect all columns but that new/unhidden column. This will force the rule to stop being an all-columns one:

  3. Then simply hide that column back:

Needless to say, the yellow rule has to be above the gradient rule. Rules apply top first, but all all-columns rules always go after all some-columns-only rules.

The downside is that whenever you add a column to your view you’ll have to repeat these steps, since the newly added column won’t be checked for that yellow rule, and checking it will again turn on the all-columns mode.

2 Likes


yep that worked :grinning::pray: