Dynamically filtered for each User

I want to let each User see a list of ONLY their tasks in the table.

Currently I have a button to select a User name, and the table filters from that.

The problem with this is that only 1 person can be using it at a time.

Is there a way to have a table view, that is filtered to only show results where column xyz = User
Where User is the logged in User to coda? So each person sees their own tasks?

OR
some other way for multiple users to view a filtered view of the table at the same time.

Hi @Sam_Giligich - There is a User() function just for this. You can set a table to filter by UserName= User()

Where UserName is the column with your username.

You can user User().Email, User().Name etc to match against the right value you have in UserName.

1 Like

Perfect!

Also, for another view, is there a way to easily filter on a particular user other to yourself?
Basically, I have a button that filters on the User, but I want it to have an option to not be filtered on anyone (or everyone).

Have you considered using a Select List Control to filter? You could choose the people you want to filter out/for.

It doesn’t seem to work as the ‘all’ in the multi select doesn’t have any result in the table. As I guess it checks against ‘all’ instead of against any given user in the list. If that makes sense?

Mind sharing your doc with support@coda.io and I can take a look. Or if you want to create a sample table + filter and share it here it will be great!

Shared, see the ‘per user’ section.

The table is filtered on the Team Member Select button, but I also want the option to remove that filter and show all rows.

If you convert the select list to a multiselect list (select the option in the Select List Setup Config) then you can select All to see all the rows.

To use a multi-select list you need to update your filter from = to Matches or Contains.
E.g
[Assigned To].Contains( [Team Member Select])

But then there’s the option to select ‘all’ isnt there? And if you do that it doesn’t work?

If you change to multiselect the option to select all is there.
And you need to change your filter to use Matches or Contain for it to work.