.Filter() is not updating based on different Data

Hi there, so I’ve created a User Profile View in Coda with a Dropdown to select the User and then multiple Tables that use .Filter() to only show the Data of this specific user.

Unfortunately Coda doesn’t apply the new selection from the Dropdown to my filters after accessing the document. I have to click on “Filters” first for every Table in order to activate the dynamic filtering again. I am pretty sure thats not how its supposed to be, any ideas?

coda issue

I just noticed that this is probably linked to the fact that coda doesn’t close the previous selection, as it shows then a second user in the detailed view. And it only affects the detailed view, for cards for example there is no problem like that.

Hi @Simon_Gerle :blush: !

I’m sorry but I’ve got to ask :innocent: : why do you use a Row UID in your filter ?

I mean, from what I see from your gif, you use a single select lookup control to select a person in the detail view but you don’t use that canvas control in your filter formula …

Here’s what I use as a filter for both views in the sample you’ll see below :

thisRow.Name = [Lookup People].Name

[Lookup People] being the single-select lookup canvas control on top :blush:

Because Names aren’t unique or even change. And we do have a lot of stuff that is connected, like Documents, Familie-Members and so on, thats why we need a unique identifier.

The result from the Dropdown is getting picked up by the formula that you can see below the dropdown, there I show the UID (Row-ID) of that User, like that I can just re-use it all the time by referencing the name of that formula (MAUID) and not “DropdownResult.UID”

Gotcha :blush: !

But I think there might be a small bug with the layout editor :thinking:
(Which has nothing to do with the filter formula though)

I was able to reproduce the “non-updating” filtered view issue you’re encountering when trying to edit the layout used in one of the views when the filter is already in place for that view and working (so the filter is actively filtering something out) :thinking:

non-updating filter

I think the layout editor somewhat stays focused/stuck on the filtered value that was in the field(s) when the layout was edited and seem to have troubles to escape that focus when the layout editor is closed :thinking:

But then, from my tests, the issue seems to be temporary.
I mean, once the filter is “re-applied” (by opening the filter menu of the concerned view) everything seems to work as expected :woman_shrugging: .

The issue also doesn’t seem to occur if everything is filtered out (so Blank is selected in the lookup control) from the view when the layout is edited.

As far as how the views are filtered, I’ve tried some variations:
(The sample used is down below)

  • thisRow.[Row UID].Contains([Canvas-ID])
  • thisRow.[Row UID].Matches([Canvas-ID])
  • thisRow.[Row UID] = [Canvas-ID]

And they all seem to work until I edit one of the layout used for one of views :thinking: .
(But it still seems inconsistent though :pensive: … and I’ve only tested this on Chrome 111+)

Have you tried to clear cache & cookies to see if it might help ? :innocent:

If it doesn’t help, I think you should contact the Support with this :no_mouth: .

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.