Filter not working

I have two controls on a table. One control is a select for Active, Expired, All. It filters the table based on a check box column. It works just fine by itself.

The second one is a date selector tied to the expiration date in the table. It also works just fine by itself.

I have these same two exact things on another table. I copied and pasted them from the other table, updated all the names. On the other table when I put both filters on I can filter by status and dates. Everything I select works fine.

But in this new table both filters work independently and do exactly as they should. But when both are put together with AND then they do not work right. It is completely ignoring one of the filters.

Ideas? How do you troubleshoot something that works by itself but refuses to work when each filter is added separately and joined with AND?

Dear @Susan_M_Davis,

Welcome to the community!

When you copy / paste the “multiple/single select” the formula will not be updated, meaning that your copied version will reference to the 1st table.

When you right-click on it you can update from what table the “multiple/single select” has to take it’s information.

As you can see in the markings below, from where the select his taking it’s info :point_down:

Right. I copied it changed it, it worked. I then copied and pasted the working filter to notepad. I did the same thing for the second filter. It worked. But when I put both filters in with AND then one of the 2 isn’t working.

Dear @Susan_M_Davis,

Quite difficult to guess, the best would be it you shared a dummy copy of your doc to review. :thinking: