How to turn a 'this row' button into an automation

I have this button in a table to send an email

Gmail::SendEmail([User's private Gmail account], thisRow.[Proposer's email], "Thanks! You've Given Us An Idea!!", Concatenate("You can revise and watch the progress of your idea ", thisRow.[Row Link], " here"))

Is there a way I can turn this into an automation that triggers when a new row is added to the table so I don’t have to come in and click the button manually?

:wave: Hey there!

You can mimic a “New Row Trigger” for automations using the Row-Changed automation trigger and having it listen to an editable column that inputs a value for new rows.

I go into the process in more detail here:

The then portion of your automation would be something like this:

RunActions(step1Result.[column with gmail button])

Let me know if you need any further help or clarification!

1 Like

Thanks @Scott_Collier-Weir! I think I got it, but it’s not working.
Here’s what I have in the rules:

Here’s my activity

Here’s the error message: (it seem like it worked once. . . )

What do you think?

Ahhhh yes. When you run automation that hit private accounts, you need to make the automation run as yourself rather than as “automation bot”

That can be found on the bottom of the automation as an option. Choose yourself!

Other possibility is that you have some incorrect settings in the actual button but I’d have to look at your button to determine.

lastly, if you use your automation as written, it will push EVERY button in the table. If you don’t want it to do that you need to:

  1. Set a disable criteria like this: TriggerColumn.IsNotBlank()
  2. Set the then criteria on your automation with the runActions() formula that I mentioned in my above post
1 Like

Ok - so I made it run as me & not a bot. But I still get that email error

I’m not sure why it’s returning ‘Location’ for testing - that’s the label of one of the rows, but it doesn’t have the trigger text in the trigger column. . .

I don’t think it’s trying to trigger all buttons in the table, it’s just not showing the full selection, Here’s what the ‘push button’ action is calling

I don’t think it’s anything in the button that’s the problem, bcz that works fine when clicked, but ??

Can I give you access to check what’s going on? How?

Share a link with scott@simpladocs.com

Thanks! did that. I have to say more here to get the minimum characters. . . .

Hey @Scott_Collier-Weir - I did give you access.
Thanks for all your help! If I don’t hear back from you in a couple days, I’ll remove that permission. Appreciate you!

Can you give me (through a DM) the direct link? I just don’t see the share in my email!

Here’s the link The SSM CoP Portal
I just have the one automation - it’s currently turned off.