I can't have a text cell with value 0,500

Hi,

I have the weirdest use case here.
Trying to fill a cell with value 0,500 and it changes the value to 500 !
Has anyone heard of this ? Is this a bug ?

Feb-01-2021 01-28-39

Thanks

It doesn’t happen for me.

Check whether your table is still a Text - in a new column, if the first values you enter are numeric, then CODA will change the column type to numeric. Also, on your system, is the , the decimal separator, or the 1000 separator?

Hi,

Thanks for the reply,
it is still displayed as text.

When you mean on my system ? Do you mean on my computer or on my coda doc ? I didn’t find a way to change that on coda doc !

image.png

I can confirm it happens to me also. I never had such use case so I didn’t run into this problem. But if you type 0,500 in text field it will get converted to 500.

@Piet_Strydom it doesn’t happen to you because you didn’t write 0 in front of , if you type just ,500 it will stay like that. But 0,500 will convert to 500 in both number and text format of column.

In number format I guess decimal separator settings could influence this formatting, but in text format it should definitely not be the case. The text you enter should stay exactly the same no matter what.

3 Likes

Hey @Thoma_BIGUERES1 – I just confirmed that I can reproduce this behavior. I’m filing a bug now and we’ll try to get this fixed up for you soon!

3 Likes

Thanks a lot, in the meantime I’ve added a workaround :wink: