Pasting data changes column formats

HI Coda,
I have a table (for client invoicing) that I paste new data into each month. Lately when I paste in my new row, values for several columns are being brought in as “Select List” format instead of the existing format. The table format gets changed upon pasting. This happens for my “task” “date” and “hours” (which were formatted as Text, Date, and Number, respectively, and which includes data values you might expect for those items.). My “time” column, format, oddly (containing a time, like 2:45 PM), comes in just fine.

In other words, I expect rows of data pasted into an existing table to inherit the column attributes of the existing table. Not sure why these are being made into “Select List” items. I think this is a new-ish “result” for me, but preceded Coda 2.0.

Any advice appreciated. If there is a more correct way to paste in information that would preserve these values, let me know!

Ah, I have more information for you. This only seems to happen if I paste data into my table when my table is EMPTY of rows (but still has column headers). In other words, when it looks like this:

if I paste on top of existing data, it seems to preserve the column formats.

However, I would expect it always to preserve the column formats. In this case, it’s not even making a “good guess” (dates should be easy to recognize as dates, for example) as to what format the items should use, so I suspect this is a bug and not by design.

Here’s a look at the “Select List” option I’m given for my Date column after pasting:

2 Likes

I’m running into the same issue. Nothing I do seems to “lock” the column format; pasting always adapts the format to something else (namely the Select List). This seems more like a bug than an intended feature (I like the auto-adapt feature but I doubt Codans wanted it to convert columns of all numbers or currency to list items).

Thank you both for the feedback!

I’m passing this along to the team. It seems like the common occurrence here is a column being changed to Select List, so I’m passing it along with that bit of feedback as well.