Pressing [TAB] to accept auto-complete not working?

Hi folks, just wondering what I’m perhaps doing wrong when I’m typing into a Canvas’s ‘Title’ entry field, and when an auto-complete is suggested, I hit the TAB as suggested, but the suggested completion text simply disappears and I’m left at the end of the line I was typing? (At the end of ‘Sun’ as displayed below.)

This is on Windows in a Chrome browser.

Any suggestions appreciated.

Hey @William_Bell, thanks for reporting this. We weren’t able to reproduce this with the autocomplete settings turned ON in Windows 10.
It works with ENTER key at our end, and here is a gif of that: Screencast at April 25th 2023 - 1.30.43 pm.gif - Droplr
I’m not seeing the tab suggestion you have attached though; that seems like something maybe specific to your device or OS?

If you could let us know the following, that’d be helpful:

  1. Your operating System version

  2. A screenshot of your autocomplete settings (of if they’re using an external autocomplete tool)

These are the settings we tried on Windows, for reference:

My apologies, this was a post made from my Work account, I have to be aware WHICH account I’m using when I’m on the Community site - you can remote this post if possible.

Thanks so much for your time, and response.
My settings looked the same as yours, minus the 3-visible options at the bottom.

I turned on the ‘Show text suggestions’ options as you displayed above and now I am receiving the suggestions from Windows (where I can click to add- the text):


But this is not as (potentially) nice as the previous behavior (I turned it back off) - I noticed you mentioned “pressing Enter”, but for me pressing Enter, or Tab just clears the suggested text and leave me where I left off typing.

I thought perhaps it may have been because I use the NoScript add-on for my browsers, but disabling that didn’t change anything, still no joy.

At one point I couldn’t get the Coda text suggestions to show up at all, but now, it started suggesting / working again (just not for what I was typing previously in the pic from my first post?), so I don’t know what’s going on.

Thanks for that. We’ve tried using the settings as you’ve described and using a few other browsers and operating systems, but unfortunately we still haven’t been able to reproduce this. Here is a visual: Screencast at April 27th 2023 - 1.21.25 pm.gif - Droplr

It could be that what you’re seeing is an edge case with your device, or something specific to some sort of extension with your browser.

Jasmine - I’m not sure what you’re showing me?

I see you typing but I’m not seeing any grayed out suggestion text that shows up when you’re typing?

As I had mentioned, at one point today, I couldn’t get Coda to suggest anything as I was typing into the Canvas Title (text field at the very top) - but then it starting giving suggestions again, and that’s when I posted.

In my table I have an “Add Note” button which creates a new related row and pops open the Canvas (“open for editing” setting) - I get suggestions, but if I hit Tab or Enter, the suggestion goes away as I described wo/autocompletion.

If you’d like me to also create a GIF of what I’m experiencing, I can, but simply I’ll see grayed out auto suggestion text along with (Tab) next to it - when I hit the Tab key, the suggestion text goes away and I’m left at the last character I had typed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.