Related Table in Layout not showing add row button

Hey Folks,

I have a related table showing in a layout. Both the current table and lookup table are unlocked. But for some reason the ‘add row’ button to add more values to the related table is not showing. See screenshot below.

What am I missing?

Hi @Astha_Parmar :blush: !

If by this

… you mean that is this a Multi-select lookup field displayed as a table in your Detail layout, then I think that what could be missing is that :

  • either your page is locked

or

  • the lookup field used to display this subtable in the detail layout might be calculated
    (i.e.: gathering those 2 rows through a formula instead of having been manually selected).

At least, this what I’ve seen while testing this :blush:

1 Like

This was super helpful.

So it is a lookup column BUT I applied a formula based sort to it (sort by x field) and then the add row option dissapeared.

Is there a way around this? Where I could have it sorted but then editable in the popout layout window?

Thank you so much for your help!
Astha

No problem @Astha_Parmar :blush: !

I’m beginning to think that I’m missing something here :sweat_smile: … I’m sorry but where did you used this formula ? :innocent:

I mean, in the sample you’ll find below, you’ll see a detail view of the [Table 1] (so you wouldn’t need to expand the row to see the various lookup fields displayed as tables)

Each lookups/subtables in the detail view are multi-select lookups going from the [Table 2] to the[Table 1] and each one of them have their selectable options sorted according to a specific Sort field in [Table 2].

So, in [Table 1] the lookup field :

  • [Lookup - Table 2 - Sorted by Sort 1] has the selectable options sorted by the field [Sort 1] in [Table 2]
  • [Lookup - Table 2 - Sorted by Sort 2] has the selectable options sorted by the field [Sort 2] in [Table 2]
  • [Lookup - Table 2 - Sorted by Sort 3] has the selectable options sorted by the field [Sort 3] in [Table 2]

But I didn’t use any formula to sort the selectable options in any of those lookup fields, I simply added a Custom sorting in the Options setting of the each one of those lookups …

And whatever I tried, I was still able to select other options for those lookups in the detail view of my [Table 1] or in an expanded row of my “original” [Table 1] :sweat_smile:

I’m sorry if I’m misunderstanding something here :innocent:

This was so helpful @Pch

So…it’s a reverse lookup column (aka refernced by), and looks like those don’t have the custom sort option built it. See screenshot below:

Hi @Astha_Parmar :blush: !

Thanks for the helpful screenshot :grin: !

This is the possibility I’ve mentioned earlier :

So, you can’t (or at least shouldn’t IMHO) have the ability to select/add new option to that specific lookup in the expanded row because the formula already does that for you :blush: : It already finds all the rows from your table [All Titles by Steps] where the I guess “manual select” lookup field [Core Title] contains thisRow … whether you sort the rows returned by the formula or not shouldn’t have changed anything :thinking:

I mean, I honestly feel there are some confusing inconsistencies in the way lookups behaves within a simple table and how they behave within an expanded row/detail display/view as a subtable :face_with_raised_eyebrow: … (and I have a doc where in the case of a reversed lookup displayed as a subtable, I’m completely incapable of doing what you’re doing here whether Sort() is involved or not) :thinking: )


Anyway :sweat_smile: … Sorry for the rant :innocent: : Even though I really wouldn’t rely on that specific “lookup as a subtable behaviour” to modify datas (it’s feels too “magical” for me) I think that instead of using Sort() you could sort directly the resulting subtable in your expanded row :blush:

In the sample you’ll find below, you’ll see once again a detail view of a table ([Table 2]) with 3 reversed lookups displayed as subtables …

The first one is unsorted and the formula is :

[Table 1].Filter([Lookup - Table 2 - Sorted by Sort 2].Contains(thisRow))

The second one is sorted using Sort() and the formula is :

[Table 1].Filter(
  [Lookup - Table 2 - Sorted by Sort 2].Contains(thisRow)
  ).Sort(false,[Table 1].Name)

And the third one is sorted in the same way I sorted the second one but using this time the “sort setting” of the subtable :blush: . (So the formula for this reversed lookup is the same as the one used for the first reversed lookup)

In that case, the select/add option still appears :blush: .

Hope this helps :innocent: