Add New Row Button is Grayed out in Subtable

The add new row button is grayed out on a subtable in a detail view:

Anyone know what the problem is?

What’s your display column on the related table? Formulaic?

Solved! Yes it was formulaic, but now I changed it and it worked. Thanks so much Scott.

Any idea why that restriction exists?


Thanks @Scott_Collier-Weir this resolved the issue on my end also.

Wanted to echo the question from @Joe_Kattan though, in the hopes that a Codian sees it. This is functionality that was working just fine before the subtable updates, so I assume (and hope) it was missed during testing and not a new limitation.

It should have always been a limitation, hard to explain on mobile, but when at my computer I’ll get a longer explanation.

Essentially, it’s all tied to the display column of a row. The display column of a row determines the viewable/searchable input for a relation column. When a display column is non-formulaic you can type in values, and add in new custom values to the drop down on the fly.

But, you obviously can’t edit formulaic columns, and therefore wouldn’t be able to type into add new custom values to a formulaic display column.

It wasn’t previously a limitation though – I used the workflow regularly.

The drop down would allow you to search the display column for the row to add, which shouldn’t matter if it’s formulaic, it can still return a searchable list. And clicking the new row button required opening the row and populating the fields that then populate the display column.

Am I misunderstanding?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.