Role was changed from an Editor to an Admin

When another user in my workspace (editor) create a document, it becomes Admin!

Why is this happening and how can I do to disable document creation for editors?

Hi and welcome to the community!

This is configurable in workspace settings. Turn off the “Any member can create docs” toggle here:

This is enabled by default. Not sure why but that’s just how it is.

1 Like

@Paul_Danyliuk is spot on. We have this option enabled by default to let anyone create docs in their workspace from the get-go. We found that having it off by default added unnecessary friction to people becoming Makers in Coda, especially given that there aren’t many downsides for most users collaborating in free workspaces. But we still have the option in workspace settings for those who prefer to have more control over their workspace.

In free workspaces, users currently get upgraded to an Admin in order to allow anyone to upgrade the workspace, at which point they’ll become the only Admin and can disable the option to have additional paid Doc Makers added accidentally. For paid workspaces that still have that option enabled, such auto-upgraded users will only become Doc Makers.

1 Like