Send Gmail "from" does not do anything

#1

Hi when I set up an automation to send an email to someone I would prefer it to be showing a different name.

Unfortunately I cannot make it to happen by filling in the “from” field. It even does not only state the name corresponding with that mailadres i.e. I get the mails as account@gmail.com instead of First Last Name of the account.

Is this someone else has experienced too?

0 Likes

#2

This is by design, specifically gmail’s design. In order to send email as an alias through a gmail account, you’ll have to register that alias. See https://support.google.com/mail/answer/22370?hl=en for instructions.

I create a number of forwarding inboxes for domains, for example, photos@mysite.fake forwards to myfakeemail+photos@gmail.com. Because mysite.fake is a GSuite account, I can register photos@mysite.fake without SMTP settings. The same is true for all gmail accounts. For other accounts, you’ll need to provide smtp settings.

1 Like

#3

It’s also a bit of an artifact for how gmail parses the “from” field.

If you adjust the text in the “from” input to take the form of Display Name <foo@bar.com>, you can control the display name explicitly.

E.g you could do something like: Auto Michael <foo@bar.com>

1 Like

#4

@Blessing_Osakue and @matthudson thanks!
The combined answer was the trick to let it work.

So I added a different mail as an alias in gmail i.e. Name@mydomain.com.
Then placed the "Name name@mydomain.com " into the from field and that works like a charm!

0 Likes