Setting default value in a multi select lookup column

Correct behaviour: When a column is set to text and to “lookup” from another table, and the column is set to not allow multiple entries, then setting a default text value works fine and Coda picks up the linked entry from the other table (puts it in a rounded rectangle).

Incorrect behaviour (Bug): When the same column as above is set to allow multiple entries then, even though the same default is set, Coda does not recognise it as a linked entry and instead simply inserts it as plain text.

Fully awesome product btw!

Hi @Geoff_Porritt ,
would it be possible to share a document with your scenario?

I actually just tried and it seems to work coherently on single and multiple select.

Thank you!

Hi @Federico_Stefanato. You’re testing me now!! :rofl:

Sure, I’ll go learn how to share a doc but please bear with me…

OK, I hope I have it right. Please let me know if this link works…

The table is the Assessment Master, and the column that is misbehaving is the Project Types (note that the Responder is the one which is working OK, but that’s on single option)

I have tried amending the Project Types to single select, and also the Responder to multi-select, and in each case the single version works and the multi version doesn’t (I don’t change the default value when experimenting)

Many thanks for taking a look.


Hi @Geoff_Porritt ,

I think I found the reason…

Your default value is a string: ("Standard"), wile the correct column type is a Project Type.

In order to have the correct reference, you should click the formula (f) button un the default value filed and either type @Standard in the formula (what I already did) or provide any kind of more sophisticated filtering.
That way, your column value will be coherent with your data type.

Let me know if it makes sense.


1 Like

Thank you @Federico_Stefanato . It’s worked a charm now.

1 Like