Strange behaviour involving Concatenate, Dates, Unicode

Hey all,
Can anyone else confirm this behaviour - it maybe my understanding is lacking… or it may indeed be a bug.
I can’t narrow it down to two variables - it only seems to rear itself when the following 3 things are used.
Try this.
Create a date column and put in a few dates
Now in a second column, make the formula
The Character 10 unicode works as intended - inserting a line feed between the date and “hello”. However, the date is now just a bunch of digits. Using todate() doesn’t seem to help.
Can anyone else confirm / let me in on what is going on?

You have this: =concatenate(DateColumn,Character(10)),“hello”

Try this: =concatenate(DateColumn,Character(10),“hello”)

My bad - I wrote the formula incorrectly in my post. It is indeed as you say …
Try this: =concatenate(DateColumn,Character(10),“hello”)
And this doesn’t work - it just gives a number instead of the date.

Weird, it’s working for me. Can you replicate it in a dummy doc and embed it here so I can look at it?

Thanks so much for sticking with me. It is - like so MANY of these things, user error.
I copied, pasted your formula in - and of course it worked. Whats going on?
Seems I just decided (ha!) that I’d use + signs inside my formula instead of commas, and my brain was just completely filtering them out.
And in the one it was working I used commas - and the one with character(10) I had plusses. Yet I looked at this damn thing many many times and didn’t see it till now.

So thankyou - its all solved. Not a bug. My Error.

1 Like