Table or card-type view

I hope someone knows an answer to the following:

When using the coda app on android (my phone), with many tables I get to see the little table icon to switch to table view, rather then a card like view:
I thought this was a default icon with every table, but when doing some testing in a new document, I don’t see this symbol anymore - even with wider tables.

Does anyone know how to turn this behavior on or off - or what parameters trigger the app in code to show a card-like (not cards though) view instead of a table view.

Off-topic: can we change from table to card view with a button, or do we need to create separate views for that?

Hmm :thinking:

I’ve just tested this (iPad) and I also get this icon… but I think it’s just part of the Mobile display of Coda.

And I’m not sure the icon appears because there are many tables but most likely because there are more columns in those tables than what the “default Mobile view” accepts, so you can browse the full length of the table by clicking on the icon.

As for a specific setting to enable/disable this behavior I couldn’t find any :confused:

1 Like

Yes, I agree with the Mobile Display part, but other than that, I can’t find any logic (and I really need to find it, because I have a serious bug (that wasn’t there until recently)). I just made a new document to demonstrate the issue, but no matter how many collums wide I make it, I don’t get the symbol with this new table. And I have 3 column tables with this symbol.

Now the strange part is: in my new document this really wide table shows…as a table and not like the block (with information from which you can’t control what show and what doesn’t). Although I haven’t been al that happy with these blocks, you could see quite a couple of things right away.

I don’t mind the ‘new’ table look that I am getting in my test doc, but if that is the way it is going to be, I want to be able to change this in my old docs to.

@Codans - please reply, because it seems to me that this is pretty fundamental and we need to know what is going on - in particular since I have a bug in my ‘old style’ view when I go to table mode.

To be honest, I barely use the mobile anymore and tend to open Coda on Chrome :roll_eyes: .

I suggested the number of columns just because in the doc I opened on the Mobile app’ that’s the only thing I could think of as to why the icon appears for some tables but not others :sweat: … Sorry :confused: .

Maybe @steph could help here :blush: !

1 Like

Maybe @steph could help here :blush: !
I hope so - I have a pretty big problem, because we need to use the app on phones and tablets (and yes, I prefer Chrome on my computer, but there is not always a choice).

1 Like

@Federico.Stefanato : have you got any idea about this?

1 Like

Hi @joost_mineur ,
to be honest, I don’t know very much about it.

I’m not using very much the mobile version myself and I’m a bit off-guard on this topic.
But I try to investigate :slight_smile:


Hi @joost_mineur, I’ve surfaced this issue to the team. I’ll be sure to update once we know more.



Hey Steph,

Thank you very much. Even though I use Coda in a daily basis, this one had gotten me completely of guard. Looking forward to some clarification, whatever the answer may be.


Hi all, here’s a bit more context on how tables appear on mobile, from this help article:

For most tables, Coda automatically chooses a mobile-optimized card layout based on the data in the table. In some cases, no card fits well and Coda will show the table…

There’s a few cases where you may still see a regular table instead of cards:
(1) If the display column is hidden, you won’t see cards since there’s not a clear column to choose as the title for the card.
(2) If your table has many numeric columns, you’ll see it as a table with column headers so it’s clear what each number represents.

The icon to view as a table should always show if the view is a table on desktop but automatically shown as cards on mobile. It’s not shown when the table already displays as a table on mobile, or if the view is card view on desktop.

If you see specific cases where this isn’t happening, let us know and we can take a look.

We’d also love to enable more customization and control over how tables show on mobile in the future!


Hello @nathan ,

Thank you for pointing me in the right direction.

The following pertains only to mobile view (on Android in my case). Looking back in my docs I recognize how Code “chooses” a certain display mode. There have been postings in the past with complaints as to how the ‘card view’ (by lack of a better word) renders the information almost useless, because if Code thinks a card view is best but you have text and number tables, there is no telling what these numbers mean, in particular if they are of similar magnitude. It also seems not very clear as to what you get to see (and where) in the cards. Playing around with column order sometimes helps, but then the the table view might not be the way you like it any more.

Since you say you’d love to allow more customization, I feel invited to come up with some suggestions.

But, and that’s why I started this thread in the first place, there is a bug in the table view, so let me start with that. It is for me an absolute killer of my application and, sorry to complain here, after almost 48 hours trying to get support to even acknowledge the issue, I will discuss the bug here and hope a (quick) solution can be found. This is something that worked until very recently.

I have pretty complex tables that show on mobile in card view. Sliding the cards, clicking on the cards (and the window version) work 100% as intended. For optimal use we need the table mode (on mobile), so we click on the little icon to table mode. And here is where things go wrong: my buttons that have a formula for the button label don’t work any more. My buttons have complicated instructions depending on the status of other fields and this label changing it’s wording is crucial. The workaround would be many more buttons, but that is not an options, since there is only so much screen real estate and I would need way to many buttons. But at this point, in table mode, these buttons with this specific functionality stay gray. Since they work in card mode and in windows, this can only be a (new) bug.

I hope you will be able to get someone to look at this in a hurry, because we have come to rely on this big time.

That said, about the customization, I have some suggestions:

  1. a canvas button function to change the card mode to table mode for a specific table. And a more obvious icon than the back arrow to return to card mode.
  2. a set of options at design time with each table to choose the default mode for the specific table. Right now, even though you can switch to table view, it becomes a full screen table and not inline, which is not always handy. So we need 3 default modes: a) card view, b) inline table view and c) full screen table view (edit: I realize this last one can’t work unless the table is the only thing on a page).
  3. allow us to choose which fields are show in card view (if there are more columns than can be placed) and per field/column allow for a label to show with the data, so you can distinguish something like: high score: 9 - average score: 7 - low score: 6, while someone’s name can show without a label, because it is obvious what it is.
  4. allow for some buttons to show in card view (rather than having to swipe)
  5. upon swiping, show only active buttons in the available space (which is only 2 buttons plus the ‘more’ button.

I can think of many more features, but this is a start. I had kind of accepted that cardview was the way it was, but this bug and your remark got me going again :grinning: . However, getting this bug fixed is a good start for me.

Thanks in advance for your consideration!


1 Like

Great customization ideas! This isn’t ideal, but one workaround to force an inline table view on mobile is to hide the display column; if you need that column to show, you could add another column with a formula that shows the same value.

We’d love to investigate the bug you described; I’ll reached out directly to follow up.


That is a workable workaround - thank you for this tip.
I am in contact with support again to check on my bug report - they have a bit of a hard time reproducing it. Please feel free to check with Renita for the details.