Undo shortcut doesn't really undo

The toast message that pops up when I add a row using a button (and choose “Open row for editing”) doesn’t actually undo adding the new row to my table(s). It closes the Details popup, but the empty row is still there, and I have to manually right-click and choose “Delete row everywhere” to get it to go away.

If this worked as expected it would be a good template (and a temporary stand-in) for a Cancel button requested elsewhere on this forum for that popup!

Hello Ian, thank you for reporting this.

I found the undo button working fine, however a known behavior is for when you have a checkbox column, when click undo it’s basically disabling the checkbox state, as you can see in the image below.

Could you verify if you have a checkbox column?


Thanks for looking into it! I do have checkboxes in my tables!

As a test, I created an empty table and a button to add a row (and show it). The UNDO link does seem to work fine there.

Then, I changed one of the columns to a checkbox, and when I click the button and click UNDO the row is not removed, and the checkbox is ‘unchecked’. So it seems you are correct.

Is this intended behavior or something that you plan to change? If the former, what would be the simplest alternative? I know I can add a Cancel button to one of my columns to manually delete the row but it seems redundant (since you can access the delete option in the menu) and a bit unsafe.

It is exceedingly easy to accidentally add useless rows to my tabless since there’s no Cancel button. I was hoping the UNDO link would serve the same purpose (and if so I’d really like to see the UNDO link added to the layout instead of a ‘snackbar’ since it disappears if you wait too long).

Thank you for confirming, you can easily prevent this happening, removing the formula for the check box column.


So it turns out that didn’t fix the problem, but it’s because I have a Date column which also has a VALUE FOR NEW ROWS set.

I removed the default values, and it works properly :partying_face:. But I do have to manually fill the Date value (at least I have to click on it, after which it will default to TODAY which is what I wanted in the first place). I can live with this but do I have to give up the default values? It seems like UNDO really should undo the entire ADDROW, rather than the way it works now.

Yes, I understand that it causes misunderstanding, but at the time you create a new row is also updating it with the default value, so each step is counted as an action, undoing is basically reverting the last change :slight_smile:

To have all covered in one step you can try adding the default values in the button actions.

That’s a reasonable solution. It does seem a little odd that setting the default values from a button get grouped in the undo history, but setting them from the column format doesn’t.

Anyways I’ll use this method!

1 Like