Why am I getting suggestions on number columns and how can I disable it?

See screenshot, and note that is is a number column :astonished:

I am fairly sure this behaviour did not exist in the past.
Unlike text columns, there is no option to disable these suggestions. They have wreaked havoc in our docs as hitting tab to move to the next column auto-selects the first number in the list.

Hello @Nad ,

I have been trying to reproduce this behavior, but I can’t. Can you share a dummy doc that does the same thing - I would really like to see this happening and find out why, because I agree this can be a real problem for the integrity of your data.


1 Like

Hi, @Nad. I have the exact same issue. @Jason_Tamulonis explained me that the data you have in this column is string instead of number.
Coda for some reason doesn’t show that red dot when you have wrong data type for this case.
I shared my doc with him so he could understand how it happened.
One way to fix it is to create a column with the formula [number column].toNumber() and the copy and paste the result to the original column. This easy fix doesn’t stop it from happening again.
Jason thought that I was inserting data using some bulk insert method which I wasn’t.
I hope they find a solution for this.

1 Like

@Breno_Nunes, your suggested fix worked ! thanks very much.
@joost_mineur : I can’t for the life of me reproduce this bug. It mysteriously appeared in a big table that has been in use for a while now. Once it appeared, it never went away until I implemented the fix above.
Like Breno’s case, this is not a table that was bulk imported, and the columns started their life as number columns (ie, they were not converted or copied from earlier text columns).

I hesitate to mark this as solved, because in some way the issue persists and clearly other users a running into the same problem.

1 Like