Why doesn't "me@emailaddress.com" = "me@emailaddress.com"?

Have created a utility table “FilterByDate” where user can specify a start date that is used to filter another table. Need to have 1 record in this utility table for each possible user and have managed that by defining a column “UserEmail” that has default value User().Email. This column is the display column and should be unique. I’ve tested it logged in as different users. When a user creates a record in this table, the users email address is entered in this column. So far, so good.

There’s a button that changes the DateStart column in this utility table. The button uses the AddOrModifyRows action. When I had just 1 row in the table, it worked okay. But I can’t get it to work now that there are multiple rows. I’m using this formula to filter the utility table:


where UserEmail is the display column in the utility table (“FilterByDate”).

I can see the value in the UserEmail column and it’s my email address. And the function User().Email returns my email address. But the formula editor for this filter in the action dialog says this formula returns false. Why doesn’t me@myaddress.com = me@myaddress.com? I’m guessing it’s got something to do with the comparison of two values that’s getting screwed up by the presence of the ampersand, but I’m not sure and I can’t figure out how to coerce these values to string values (if they’re not already) for comparison or to escape the ampersand (if it needs to be escaped).


Dear @William_Porter,

Would you mind to share a dummy copy? It much more easy then to reproduce a new doc without being sure that your logic is available?

Hi @William_Porter,
I even tried to reproduce it, and it actually works… so I second what @Jean_Pierre_Traets suggests: your real context would help to dig into it a bit more

Thank you!