All navigation buttons broken

People using our documents have just noticed that all our buttons in our doc that take the user to different sections are no longer working.
An example formula being used inside te button is
In the past, this would stay in the current browser tab and open the correct section.
Now it opens a new browser tab and (rightly) throws up a browser error.

Has something changed on the back end for coda that would cause this issue?

What would you suggest we do to fix it?

EDIT : Just saw this in the bugs section…but I’m don’t think this is related to what I’m seeing

What I’m guessing has changed is the way coda allows you to use just part of the URL in the past. This was great, as the same buttons could be used in a published doc or in the edit doc (which would have different front parts of the URL)

Or is there something else at play?

Is it better to use the hyperlink formula? (But that’s not a drop-in replacement either AFAIK)

Any help is much appreciated.

I tested this in Chrome with the following formula setup and it worked.

Concatenate(thisDocument.Url(),"/[PAGE ID]").Hyperlink()

[PAGE ID] is just the _xxxxx after the page name in the URL.


Thanks. I’ve managed to find all the buttons / change all my formulas. Working again.
Still doesn’t explain why it worked for 9 months and then suddenly stopped.