BUG:Filename pasted into TEXT fields are interpreted as Hyperlinks

Hello, Codans, I’ve been dealing with this issue for a while now, and I’m hoping for a solution.

In my Coda doc where I keep track of all my photos and videos, I’m running into a situation where when I simply paste either a pathname to a file or just a simple filename.ext(ension) into a table’s Text field, Coda treats the text as a hyperlink, requiring me every time, to edit the text in the field and Remove the hyperlink attribute off the text.

The sources are copying filenames out of the Windows file manager and directly pasting into the Text cell in Coda’s table - I even created some dummy filename in Notepad, thinking perhaps the File manager was doing something with the formatting of the text - the same issue is exhibited:

(CTRL-V], then [CTRL-SHIFT-V] - all NO JOY!):
Coda-Filenames Pasted into TEXT field act as Hyperlinks

I’ve tried [CTRL-V], [CTRL-SHIFT-V] and out of desperation, [CTRL-ALT-SHIFT-V] (which does nothing.

If I simply put a space before the file extension e.g.: “5vrjo4zmx529Original .mp4”, then Coda correctly interprets the text as plain text.

Any workaround or a fix from Coda would be highly appreciated since having to edit the field value after every paste is tedious as’All-Hecks!


1 Like

I just tried replicating this problem and cannot get the same behavior. Can you share a doc that exhibits this issue? Or could you let us know what column options values of column the display column of the “File Take Details” table are configured to be (especially what type of column it is)?

1 Like

Hi Eric, thanks for taking the time to check - the individual file details are actually stored in a sub-table (hence the +Add / -Del buttons in the parent table)

The File Take table holds the details for the individual files: here’s the column details:

The Filename is the Display Column for the row - I guess I could try later using a non-display Text column and see if that makes a difference.

Going directly to the sub-table where the file details are stored and adding a new row:
File Take Details Table - same issue

I am also unable to replicate this… would you be able to share the doc? Have you tried testing this in a different browser?

1 Like

Thanks Micah as well.

I will say that when creating some of my capture images - the pasted filenames would display correctly once or so, but then fall back to ALWAYS being a hyperlink.

This was all using Chrome, btw.

I just now logged out of Chrome, and into MS Edge (ugh! I have a love/hate affair with Edge), but I will say so far, every filename I’m pasting comes in as plain text, not hyperlinks.

I’ll continue with this for the time being, and also see if I can wrangle all the popups, news, Ad links, and total control MS wants for this browser (and Windows 11)…

I’d be nice to figure out what’s up w/Chrome - the main plugins I use are NoScript (which I disable to see if that was interfering w/Coda), Bitwarden, and the Evernote WebClipper.

Thanks everyone! :ok_hand:

1 Like

WHOOPS never mind,

…It’s started again…” - Morbius, Forbidden Planet

Why it worked a couple of times, and now it’s doing it in Edge - goodness!

I did add NoScript and EverNote web clipper - let me remove them and see if that helps.

I’ll look into creating a Doc I can share…


Ok, I did some further testing.

At first, I thought it was perhaps because I extensively use VeraCrypt on my drive partitions to encrypt all my data drives internal and external within removable USB drive enclosures.

But testing those drives, and then say my C: (Win 11 OS), drive which isn’t encrypted didn’t yield the results I expected.

I finally did some tests with some music video files I have on my G: (non-encrypted “Media”) drive and discovered this:

Okay (Not Hyperlinked):
Chaka Khan - Baby Me.mpg
Deon Estus - Heaven Help Me.mpg
Shanice - It’s For You.mpg
Shanice-It’s ForYou.mpg (removed all but one whitespace)
a b.mp4 (test 1 whitespace character)

Not Okay (Hyperlinked - NO whitespaces at all):

Anytime there’s not a space, or something to break up the text into “words”, I end up with a hyperlinks I have to then edit to remove.

If the text naturally has a space (I haven’t tried any other non-alphanumeric separator chars), then there’s no issue when the text is pasted into the Title / Filename field.

This was tested using Edge, but the behavior originated with my exclusive use of Chrome.

The majority of my path and filenames have underscores, and dashes, very few whitespaces, and other “exotic” / (legal) non-alphanumeric characters in my filenames.

William, you might try simplifying your use case to see if the problem really is the field or something else. Have you tried my super-stripped-back example doc? I’d be curious if you have the same problem there.

Whether or not the column is the “Display Column” should not make a difference, but perhaps it does. I’d be very curious to know exactly what is in your paste buffer, as there can (at least on the Mac) be things in the paste buffer that are not plain-text and might have an impact. But that can be hard to determine. Certainly tools that might modify the clipboard could also have an impact (they might be outsmarting you!).

Good luck sorting this out!

1 Like

Hey Eric, I don’t know if you saw my last results above (we may have been cross typing) but I only have issues if the filenames don’t have any spaces within the file / pathnames.

I created a brand new table w/ default columns - same issues.

I tested your shared table and pasted a filename directly out of my Windows File Explorer:

Since you’re on Mac, and I’m on Windows 11 (and sometimes Win 10 on a laptop), the testing isn’t apples to apples (whoops!)

Thanks care, and again thanks for helping me attempt to figure out what’s going on here.

…Actually, my wife has a Macbook Pro - I’ll try my page on her laptop tomorrow!

Yeah, I saw you in there! :slight_smile:

I am pretty sure that what is happening is that something on the Windows side is adding the link to the text when you copy it. Something is being clever and trying to help you out.

But curious to know what you learn.

1 Like

Ok Eric, again thanks because I never would have thought to test on a MAC.
(LOL, first I had to get used to using Alt-C / Alt-V)!

Here’s what I tested:

a b.mp4
This is a test.mpg

NONE of them exhibited the “hyperlink” issues I’m experiencing on Win11 & Win10!

With spaces or without - all pasted into my tables as text on my wife’s Mac using Safari…


I have a situation where I don’t really need email addresses to be a link and the ONLY reason I preferred them not to be is I create a PDF of a membership list to print out. When they are links, they are blue. Not a big deal so I leave it. However, what I noticed is…

If I type or paste an email address into the field and tab to the next field, it does not become a hyperlink. If I type or paste an email address into the field and enter it by hitting return, it becomes a hyperlink. I am using Chrome on a Mac.

1 Like

Super anecdotal but I work with .mov files a lot and .mov also happens to be domain suffix.

I too have had some issues with file names becoming URLs - on Mac here - so discount Windows.

1 Like

^Thanks Gareth for mentioning what you’ve experienced regarding this issue.

Coda, can you please offer some insight on this problem that I’m experiencing - it’s 100+% reproducible for me?

Just imagine when you have THOUSANDS (with a B… um…, T), of photos etc., that you’re trying to keep track of (finally), and you have to correct every filename that’s added into Coda’s database!

It’s driving me batty - help!

Edit - Just to reiterate - this is on Windows, not Mac (didn’t experience any of this on my wife’s Mac).

I have no idea what changed, previously I couldn’t even replicate your issue, but now I’m constantly running into this as well :confused:

I am also on Windows and have tried the most up to date versions of Chrome & Edge with no extenstions.

Pasting with CTRL + Shift + V also doesn’t change anything.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.